Outils pour utilisateurs

Outils du site


reseaux:cisco:routage

CISCO Routeur : Routage statique/dynamique

Network
Cisco CCNA
Le routage des paquets d'un réseau de source vers un réseau de destination par le transfert de routeurs est possible avec 2 configurations : statique ou dynamique. LOL

Implémentation du routage statique

  • Le routage statique consiste à indiquer l'aiguillage des paquets sources pour un réseau de destination inconnu. Les routes statiques sont renseignées par l'administrateur et stockées dans la table de routage.
Exemple:

Exemple

Si le poste PC1 du réseau 192.168.1./24 cherche à contacter le PC2 du réseau 192.168.2/24,
le routeur R1 ne connait pas nativement le réseau de destination puisqu'il n'est directement connecté.

Il faut lui assigner la route statique qui aiguillera les paquets vers le prochain routeur R2. Le routeur R2 connait le réseau 192.168.2/24 car il est directement connecté.

Le principe est le même pour le retour du paquet. Donc dans cet exemple, 2 routes à jouter :

  • Sur le routeur R1:

Soit on définit la route statique pour le réseau de destination :

ip route 192.168.2.0 255.255.255.0 10.0.0.2
Soit la route par défaut (tout réseau inconnu vers le prochain routeur) :
ip route 0.0.0.0 0.0.0.0 10.0.0.2

  • Sur le routeur R2:

Soit on définit la route statique pour le réseau de destination :

ip route 192.168.1.0 255.255.255.0 10.0.0.1
Soit la route par défaut (tout réseau inconnu vers le prochain routeur) :
ip route 0.0.0.0 0.0.0.0 10.0.0.1

  • A savoir, dans une architecture réseau plus complexe, il est possible de définir une route par défaut via une interface et des routes statiques via une autre interface. ;-)

Implémentation du routage dynamique

Heureusement, les fabricants de routeurs ont mis au point des protocoles de routage dynamique. Ce qui signifie qu'en activent ces protocoles sur les routeurs, ils vont se communiquer les routes. Le routage dynamique apporte les notions de :

  • échange de table de routage
  • redondance
  • choix de la meilleure route (vecteur de distance / topologie de liaison)
  • temps de convergence

Nous aborderons différents protocoles dynamiques qui peuvent être associés. Afin de hiérarchiser les différentes routes apprises dynamiquement, chacun d'entre eux possèdent une métrique administrative. La métrique administrative la plus basse est prioritaire sur les autres.

Présentation Définition Métrique administrative
C Connected 0
S Static 1
E EIGRP 90
O OSPF 110
R RIP 120
  • Les métriques administratives sont visibles avec la commande :

show ip protocols

Le protocole RIP

RIP

  • RIP : Routing Information Protocol
  • Version 1 : prise en charge d'IP ClassFull (A en /8, B en /16, C en /24)
  • Version 2 : prise en charge d'IP ClassLess (CIDR / VLSM)

Administration de RIP2

  • Activer le protocole RIP 2

conf t
router rip
version 2

  • Définir les réseaux publics connectés, ceux qui seront transmis par la MAJ RIP:

network 2.0.0.0
network 3.0.0.0

  • Par recommandation, si votre infrastructure contient IP ClassFull et ClassLess :

no auto-summary

  • Modifier l'intervalle de mis à jour RIP:

timers basic 10 10 10 10

Vérification

  • Constater les routes apprises (R):

sh ip ro

  • Activer le debug sur le protocol RIP pour coir les MAJ envoyées et reçues:

debug ip rip

  • Visualiser les protocoles actifs:

sh ip protocols

Le protocole OSPF

OSPF

  • OSPF : Open Shortest Path First
  • Plus pertinent que RIP lors de multi-liaisons (état de liens)
  • Attribution d'un côut par route (calcul en fonction de la bande passante)
  • Avantage d'être OpenSource donc compatible de toutes marques

Administration de OSPF

  • Activer le protocole OSPF:

conf t
router ospf F1

  • Définir les réseaux publics connectés avec le masque inversé dans l'aire 0 (backbone) transmis par la MAJ OSPF:

network 2.0.0.0 0.0.0.255 area 0
network 3.0.0.0 0.0.0.255 area 0

Vérification

  • Visualiser les routes :

sh ip ro

  • Information sur les protocoles actifs :

sh ip protocols

Le protocole EIGRP

EIGRP

  • EIGRP : Enhanced Interior Gateway Routing Protocol
  • Protocole de routage propriétaire CISCO
  • Association de 5 métriques / route (Délai / Bande passante / Fiabilité / Charge / MTU)
  • Utilisation de l'algorithme DUAL ( pas de bouclage / convergence rapide)

Administration de EIGRP

  • Activer le protocole EIGRP:

conf t 
router eigrp 100

  • Définir les réseaux publics connectés avec le masque inversé, transmis par la MAJ EIGRP:

network 2.0.0.0 0.255.255.255
network 3.0.0.0 0.255.255.255

  • Par recommandation, si votre infrastructure contient IP ClassFull et ClassLess :

no auto-summary

  • Modifier les variances pour le calcul des routes primaires et secondaires:

traffic-share balanced

  • Définition du nombres maximum de routes possibles :

maximum-paths 4

  • Définition du nombre de sauts maximum :

variance 20

Vérification

  • Visualiser les routes :

sh ip ro

  • Visualiser la topologie (primaire / secondaire) de EIGRP :

show ip eigrp topology

reseaux/cisco/routage.txt · Dernière modification: 15/04/2016 à 21:15 (modification externe)

Outils de la page